MSX Village forum

L'atelier [Réglé] Création des signaux du YM5214

metalgear2 Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 27/11/2010 à 23h40

Messages: 2768

Le 03/03/2014 à 17h31
Bonjour,

Voilà deux à trois semaines que je me bats pour recréer les signaux du YM5214 sans résultats.

Ne trouvant pas de solution avec un EPM7128 pour recréer les signaux je me suis rabattu sur une autre solution, une version a base de 74LSxx.

J'ai repris le schéma d'un MSX1, le VG8010 qui est apparement, assez simple ... enfin, c'est ce que je pensais ... :oups



Avant toute chose, j'ai testé le MSX avec le C.I d'origine, il démarre :



J'échange le YM5214 par la carte fille que j'ai fais :



Résultats :'( :

Le relais colle.

Sur le CX5M, la PIN20 et 22 de la ROM BASIC se touchent alors que sur le VG8010, la PIN20 est sur ROMCS et la PIN22 sur SLTSL0. Si je débranche la PIN22, le relais ne colle plus. J'ai donc essayer de mettre la PIN22 sur le SLTSL0 ... rien.

Là, je comprends plus rien, je lui envois bien les signaux qu'il faut et il ne démarre pas. :oups

Si quelqu'un avait une idée ou un p'tit truc que j'aurrais peu-être oublier, elle serait la bienvenue. :siffle Edité par metalgear2 Le 03/03/2014 à 17h48



Mon site consacré au MSX : http://mymsx2.free.fr
Site web    
Fabf Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 24/08/2010 à 20h55

Messages: 4833

Le 03/03/2014 à 18h51
Dommage que tu te rende compte que maintenant que la ROM est piloté par le même signal sur /OE et /CS :moue

Tu peux tenter de mettre directement /SLTSL0 sur /ROMCS.
metalgear2 Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 27/11/2010 à 23h40

Messages: 2768

Le 03/03/2014 à 19h07
Fabf :
Dommage que tu te rende compte que maintenant que la ROM est piloté par le même signal sur /OE et /CS :moue

Tu peux tenter de mettre directement /SLTSL0 sur /ROMCS.




Bin si, je m'en suis aperçu quand j'ai réaliser l'extension MSX2 il ya quelques mois, mais je me suis pas plus inquiéter.



Maintenant si, je m'inquiéte. :'( Edité par metalgear2 Le 03/03/2014 à 19h07



Mon site consacré au MSX : http://mymsx2.free.fr
Site web    
Fabf Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 24/08/2010 à 20h55

Messages: 4833

Le 03/03/2014 à 19h09
Surtout qu'on retrouve pas de MSX dans MSXengine qui fonctionne comme ça :moue

Jipe est sur le coup on dirait ;)
metalgear2 Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 27/11/2010 à 23h40

Messages: 2768

Le 03/03/2014 à 19h13
Fabf :
Surtout qu'on retrouve pas de MSX dans MSXengine qui fonctionne comme ça :moue




Tu veux dire " ... pas de MSX sans MSXEngine" où " ... pas de MSX dans MSXEngine" Edité par metalgear2 Le 03/03/2014 à 19h35



Mon site consacré au MSX : http://mymsx2.free.fr
Site web    
Fabf Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 24/08/2010 à 20h55

Messages: 4833

Le 03/03/2014 à 19h33
Surtout qu'on retrouve pas de MSX sans MSXengine qui fonctionne comme ça ;)
metalgear2 Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 27/11/2010 à 23h40

Messages: 2768

Le 03/03/2014 à 19h41
Bin si justement, et j'en ais potasser des plans.

Le PIONNER TX7 :

Il a peut-être un genre de YM5214, mais n'a aucune influence sur les signaux de la ROM, il a son propre décodage a base de 74LSxx. C'est même là que j'ai remarqué un astuce pour CAS2 et CAS3.






Mon site consacré au MSX : http://mymsx2.free.fr
Site web    
Fabf Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 24/08/2010 à 20h55

Messages: 4833

Le 03/03/2014 à 19h55
En regardant le schéma complet on voit que /SLTSL0 et /CS0 passe dans IC43 (74LS32).

A toi de jouer ;)
Jipe Membre non connecté

Maire-adjoint

Rang

Avatar

Association

Inscrit le : 02/10/2009 à 19h41

Messages: 9531

Le 03/03/2014 à 20h22
sur le CX5 les pins 20 et 22 de la rom vont sur le signal /ROMCS

sur le VG8010 le 20 est sur /CS01 et le 22 sur /SLTSL0

il suffit donc d'appliquer les 2 signaux du VG8010 sur ta rom de CX5


:noel
Site web    
metalgear2 Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 27/11/2010 à 23h40

Messages: 2768

Le 03/03/2014 à 20h41
Jipe :
il suffit donc d'appliquer les 2 signaux du VG8010 sur ta rom de CX5




Est-ce que je peux par exemple utiliser une porte logic d'un 74LS32 avec CS01 et SLTSL0 en entrée, puis utiliser la sortie pour la ROMCS ?





Mon site consacré au MSX : http://mymsx2.free.fr
Site web    
Fabf Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 24/08/2010 à 20h55

Messages: 4833

Le 03/03/2014 à 20h45
Ca me parait clair ;)

Jipe Membre non connecté

Maire-adjoint

Rang

Avatar

Association

Inscrit le : 02/10/2009 à 19h41

Messages: 9531

Le 03/03/2014 à 21h13
je pense que tu ne veux pas modifier les signaux de rom d'origine sinon pourquoi tu n'appliques pas directement le décodage du V8010 ?


:noel
Site web    
metalgear2 Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 27/11/2010 à 23h40

Messages: 2768

Le 03/03/2014 à 21h33
Jipe :
je pense que tu ne veux pas modifier les signaux de rom d'origine sinon pourquoi tu n'appliques pas directement le décodage du V8010 ?




Tu veux dire : envoyer SLTSL0 à la PIN22 et CS01 à la PIN20 ?



Si c'est ça, j'ai déjà fais l'essai sans succer.



Par contre, j'ai vu sur le schéma du VG8010, PIN20, un signal CSM. J'ai pas trouver et en plus il manque une page du service manuel. :'(





Mon site consacré au MSX : http://mymsx2.free.fr
Site web    
Jipe Membre non connecté

Maire-adjoint

Rang

Avatar

Association

Inscrit le : 02/10/2009 à 19h41

Messages: 9531

Le 03/03/2014 à 21h50
le schéma du VG8020 utilise la même méthode que le VG8010

ton cablage est peut être bon a ce niveau la et c'est ailleurs que ça coince

sans la ROM pas de clic car c'est elle qui contient les lignes de programme et si il manque un périphérique ça plante


:noel
Site web    
metalgear2 Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 27/11/2010 à 23h40

Messages: 2768

Le 03/03/2014 à 22h14
Petite modif avec un 74LS32 :

Le relais ne colle plus mais toujours écran noir.






Mon site consacré au MSX : http://mymsx2.free.fr
Site web    
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie