MSX Village forum

L'atelier Mapper 4Mo CPLD + DRAM

Fabf Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 24/08/2010 à 20h55

Messages: 4833

Le 04/10/2013 à 18h07
Malheureusement, cette fois je poste un truc non fonctionnel dans la rubrique CPLD :(

J'ai mis en place un mapper 4Mo dans un EPM 7128 avec une barrette SIMM30 de 4Mo 2 chips.

Mon TurboR m'affiche bien les 4096ko supplémentaires, TESTRAM aussi.

Par contre TESTRAM me donne des erreurs (presque toutes les pages) dans la phase 2 du test.

PSGSAMPLER reconnais bien les 4096 mais ne charge pas un fichier de 4Mo complet.
Environ 2Mo selon mon estimation.
La relecture est bonne.

J'ai testé le mapper ASCII, le mapper Jipe et le mapper ADDRAM.
Tous donnent les mêmes résultats seulement si on utilise la partie RAS/CAS du mapper ASCII.
Les deux autres ne fonctionnent pas en CPLD (ou alors je sais pas faire :oups )

Résultats :
Je suis sur à 90% sur que la partie mapper est bonne
Je suis sur à 50% sur que la partie RAS/CAS est bonne
J'ai de plus en plus de doute sur le bon fonctionnement de ma SIMM30. :(

Je vais commander un connecteur pour SIMM30 comme ça je pourrais tester d'autres barrettes plus facilement.

Toutes les idées sont les bienvenue ;) Edité par Fabf Le 29/12/2014 à 18h39
galine Membre non connecté

Conseiller Municipal

Rang

Avatar

Inscrit le : 27/08/2010 à 02h22

Messages: 1363

Le 04/10/2013 à 19h23
tu as fais la mauvaise pioche de barette je penses
Google+    
Fabf Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 24/08/2010 à 20h55

Messages: 4833

Le 04/10/2013 à 19h26
Je pense aussi mais ça peut être tellement d'autres choses.
Je suis partie sur SIMM pour la simplicité et au final :(
MSXlegend Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : Shoutbox

Inscrit le : 18/06/2010 à 22h42

Messages: 4905

Le 04/10/2013 à 19h33
As tu verifié le voltage :hum Edité par MSXlegend Le 08/10/2013 à 09h19


[NMS8250 MSX2+,4mo] ,SCC,Moonsound,Fm Stéréo,Music module,Sunrise CF,GFX9000,MFR,Console NeoDream,1PiMSX.
[NMS8220 MSX2+, FM, COVOX, Tada MIDI] ,Exp 4x, 512k RAM
Fabf Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 24/08/2010 à 20h55

Messages: 4833

Le 04/10/2013 à 19h45
J'ai pas trouvé d'info sur les chips utilisés :oups
metalgear2 Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 27/11/2010 à 23h40

Messages: 2768

Le 04/10/2013 à 19h55
Je sais que quand j'ai fais mon extension 1 méga sur mon 8235/39, j'avais des problémes avec certaine barette, au niveau de la rapiditée.

J'avais bien fait de mettre un support SIMM. ^^



Mon site consacré au MSX : http://mymsx2.free.fr
Site web    
Jipe Membre non connecté

Maire-adjoint

Rang

Avatar

Association

Inscrit le : 02/10/2009 à 19h41

Messages: 9531

Le 04/10/2013 à 20h06
fait une photo des puces de ta SIMM ça permet de déterminer le type de mémoire


:noel
Site web    
Fabf Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 24/08/2010 à 20h55

Messages: 4833

Le 05/10/2013 à 11h59
Sur les RAMs il est écris ça :
9702 L USA
MT4LC4M4E8DJ

Je ferais des photos dans la journée.
Fabf Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 24/08/2010 à 20h55

Messages: 4833

Le 05/10/2013 à 12h02
J'ai trouvé le datasheet :
http://pdf.datasheetcatalog.com/datasheet/micron/MT4C4M4E9TG.pdf
Ca a l'air d'être de la EDO :( Edité par Fabf Le 05/10/2013 à 12h02
Jipe Membre non connecté

Maire-adjoint

Rang

Avatar

Association

Inscrit le : 02/10/2009 à 19h41

Messages: 9531

Le 05/10/2013 à 12h42
moi aussi ton modéle est en 3,3V donc compatible si ton CPLD est en 3,3V

4 MEG x 4 EDO DRAM PART NUMBERS
PART NUMBER Vcc REFRESH PACKAGE REFRESH
MT4LC4M4E8DJ 3.3V 2K SOJ Standard
MT4LC4M4E8DJS 3.3V 2K SOJ Self
MT4LC4M4E8TG 3.3V 2K TSOP Standard
MT4LC4M4E8TGS 3.3V 2K TSOP Self
MT4LC4M4E9DJ 3.3V 4K SOJ Standard
MT4LC4M4E9DJS 3.3V 4K SOJ Self
MT4LC4M4E9TG 3.3V 4K TSOP Standard
MT4LC4M4E9TGS 3.3V 4K TSOP Self
MT4C4M4E8DJ 5V 2K SOJ Standard
MT4C4M4E8DJS 5V 2K SOJ Self
MT4C4M4E8TG 5V 2K TSOP Standard
MT4C4M4E8TGS 5V 2K TSOP Self
MT4C4M4E9DJ 5V 4K SOJ Standard
MT4C4M4E9DJS 5V 4K SOJ Self
MT4C4M4E9TG 5V 4K TSOP Standard
MT4C4M4E9TGS 5V 4K TSOP Self


:noel
Site web    
Fabf Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 24/08/2010 à 20h55

Messages: 4833

Le 05/10/2013 à 12h48
Pour une fois que j'utilise un CPLD en 5V :lol

:(

Je vais attendre mon connecteur SIMM30 pour tester d'autres barrettes.
Fabf Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 24/08/2010 à 20h55

Messages: 4833

Le 07/10/2013 à 22h16
Voltage on VCC Pin Relative to VSS:
3.3V ................................................................ -1V to +4.6V
5V ...................................................................... -1V to +7V
Voltage on NC, Inputs or I/O Pins Relative to VSS:
3.3V ................................................................ -1V to +5.5V
5V ...................................................................... -1V to +7V
Si je met 3.3V au VCC est ce que ça peut fonctionner ou l'EDO est à proscrire ?
MSXlegend Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : Shoutbox

Inscrit le : 18/06/2010 à 22h42

Messages: 4905

Le 08/10/2013 à 11h18
Je m'en doutait pour les 5v !! Mes upgrates se font avec de l'edo et ça ronronne plutot bien :tchin


[NMS8250 MSX2+,4mo] ,SCC,Moonsound,Fm Stéréo,Music module,Sunrise CF,GFX9000,MFR,Console NeoDream,1PiMSX.
[NMS8220 MSX2+, FM, COVOX, Tada MIDI] ,Exp 4x, 512k RAM
Fabf Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 24/08/2010 à 20h55

Messages: 4833

Le 08/10/2013 à 12h11
Je vais essayer de passer VCC en 3.3V en espérant que la RAM ai pas morflée :D
Fabf Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 24/08/2010 à 20h55

Messages: 4833

Le 08/10/2013 à 22h06
J'ai passé le SIMM30 en 3.3V.
Ca marche toujours pas mais c'est différent.
Plus d'accès à la BEER ou au drive.
TESTRAM en ROM m'affiche toujours 4096ko mais trouve des erreurs en passe 2.
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie