MSX Village forum

L'atelier [RESOLU] Expander X4 sur Nappe SCSI. Expander X4 de Jipe remanié sur Nappe Souple.

igal Membre non connecté

Conseiller Municipal

Rang

Avatar

Association Groupe : Shoutbox

Inscrit le : 29/07/2010 à 17h19

Messages: 5488

Le 18/07/2013 à 21h39
Salut à tous.

Afin de répondre à la demande (de Galine), j'essais de trouver un moyen plus rapide pour câbler en parallèle 6 Connecteur Edge 50.

Après quelques essais, je n'ai pas trouvé meilleur solution que de mettre les connecteurs [Edge 50 Femelle à souder] sur des connecteur [IDC 50 mâle à sertir].

1) Dans un premier temps il faut sertir les 6 conneteurs IDC 50 Male sur la nappe.

2) Il faut préparer les les Connecteurs Edge 50 Femelle en tordant les pins à 45° vers l’intérieur de sorte à les faire chevaucher avec les Pins des connecteurs IDC 50.

3) Il ne reste plus qu'à souder avec minutie. Une panne coudée en pointe (genre griffe de dentiste) convient parfaitement à cette opération.

Voila ou j'en suis.


Disons que la partie la plus facile est terminée.

Il reste les étapes suivantes:

A) Isoler 4 [Sltsl] et [BusDir]sur 4 connecteurs Edge consécutifs.

B) Couper, dénuder et souder les 48 Pins restantes de la Nappe sur le connecteur [IDC 50 Mâle Mâle]. (Cela me sert à renvoyer le câblage sur l'autre face)

C) Raccorder les signaux nouvellement envoyés sur le connecteur [IDC 50 Mâle/Mâle] vers le Connecteur [IDC 50 Femelle Coudée].

D) Fixer très très solidement et de façon irréversible (Glue 3 !?!?) les 6 connecteurs IDC (qui se trouvent à la base sous la nappe SCSI) sur la plaque de prototypage.

E) Mettre en place les 9 puces et le câblage qui va avec.

Le but est d'obtenir l'équivalent de ça:


Sans avoir à tricoter tout ça (Les fils parallèles du centre :oups )


A suivre...

@Fabf: Il me semble que t'avais fait un montage sur nappe; Peux tu me dire comment tu a fixer les connecteurs s'il te plait ^^ Edité par igal Le 25/07/2013 à 23h06


Tiens... voila du boudin, voila du boudin, voila du boudin... :siffle
Fabf Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 24/08/2010 à 20h55

Messages: 4833

Le 18/07/2013 à 21h45
Avec de l'araldite ;)

Dommage d'utiliser des connecteurs à souder, tu aurais du prendre ça :

http://www.stquentin-radio.com/?page=info_produit&info=6225&color=3&id=0&act=0
igal Membre non connecté

Conseiller Municipal

Rang

Avatar

Association Groupe : Shoutbox

Inscrit le : 29/07/2010 à 17h19

Messages: 5488

Le 19/07/2013 à 12h21
@Galine: T'as du bol, j'ai trouvé les 11 CI différents nécessaires à l'Expander. (à part un ou deux HC en remplacement de LS)

Malheureusement il me reste plus d'étain. Légend m'avait dépanné de quelques tours mais j'ai bouffé ça à vitesse grand V :|

Voici les Ci montés sur sockets.


Pour l'étain, vais essayer d'aller au mirage des ondes après la sieste de ma fille ^^

Nb: J'ai serti en bout de nappe avec un connecteur IDC 50 Femelle. L'intérêt étant que je peu plugger simplement sur un connecteur IDC50 Mâle/Male et donc renvoyer le câblage sur la bonne face de la Plaque à prototypage.

La suite s't'aprèm ;)



Tiens... voila du boudin, voila du boudin, voila du boudin... :siffle
igal Membre non connecté

Conseiller Municipal

Rang

Avatar

Association Groupe : Shoutbox

Inscrit le : 29/07/2010 à 17h19

Messages: 5488

Le 21/07/2013 à 09h43
Voila ça commence à prendre tournure ;)


Je dois juste couper un socket un peu trop grand pour des raisons esthétiques.

Concernant la distribution des [SLSLT] et [BUSDIR], plutôt que de couper la nappe, je dessouderai les Pins 4 et 10 que je relierai directement aux sorties du LS qui convient.

Les 2 autres Connecteur EDGE auront quant à eux les signaux [SLTLT], [INT] et [BUSDIR] dessoudés de sorte à être strictement parallèle au Bus MSX :top

Voici le tout début de tissage sur la droite. (ça ressemble à des points de suture)

Tout le décodage sera câblé sur la gauche. Les signaux du BUS sont transmis par la nappe SCSI sur l'autre face.


Tiens... voila du boudin, voila du boudin, voila du boudin... :siffle
galine Membre non connecté

Conseiller Municipal

Rang

Avatar

Inscrit le : 27/08/2010 à 02h22

Messages: 1363

Le 21/07/2013 à 09h53
Le truc de fou je ne consultes pas pendant quelques heures et qu'est ce que je découvre ^^.

Igal tu pourras me faire la liste des composants que je vas devoir te recommander une fois de retour en France stp

En tout cas je te remercies ça va vraiment me rendre service.
Google+    
igal Membre non connecté

Conseiller Municipal

Rang

Avatar

Association Groupe : Shoutbox

Inscrit le : 29/07/2010 à 17h19

Messages: 5488

Le 22/07/2013 à 13h28
@Galine:

Afin de faciliter l'utilisation, j'ai décidé de mettre en place 3 série de 6 Jumper [SLOT SELECT], [INT] et [BUSDIR].
En supprimant [SLOT SELECT] et [BUSDIR] tu obtiens transforme le connecteur EDGE de ton choix en I/O.

Dans la pratique, on a pu voir qu'en désactivant [INT], on pouvait utiliser le YM2413 d'une FM-PAC sans sa ROM.
(Libre à toi de tester sur d'autres périphériques ;) )

En allant plus loin, tu peux même croiser ces signaux pour faire du "Fishing" avec un BIOS résidant sur un autre périphérique.
(Dans la pratique, tu place la FM-PAC ou MOONSOUND sur le connecteur EDGE "X" et tu "Jump" [Slot Select] et [Bus Dir] vers un autre connecteur EDGE "Y".

une série de Jumpers pour interrompre au choix [SOUND IN], [GND], [+5V], [+12V] et [-12V].
Libre à toi d'alimenter ton Expander avec une source de courant "Autre".
Indépendamment, tu peux empêcher le SON d'entrer dans le MSX.





Au passage, j'ai terminé de câbler le "Tout" en parallèle. Me reste à supprimer les signaux cités au dessus, bifurquer les signaux qu'il faut et câbler le décodage au complet :fou


Tiens... voila du boudin, voila du boudin, voila du boudin... :siffle
SveN Membre non connecté

Villageois

Rang

Avatar

Groupe : compte ++

Inscrit le : 22/11/2011 à 21h14

Messages: 865

Le 22/07/2013 à 13h38
Le soleil méditerranéen a un impact indéniable sur l'activité cérébrale !!
... sauf pour les racailles porteurs d'une casquette pour le moins permanente !! :lol


Philips.NMS.8245/50/80, Sony.F1XV/HBF-700D, Pana.FSA1FX/A1WX(x2)/A1GT, OCM, GR8BIT.... et ...
   
galine Membre non connecté

Conseiller Municipal

Rang

Avatar

Inscrit le : 27/08/2010 à 02h22

Messages: 1363

Le 22/07/2013 à 17h39
Encore quelques soudures ^^… enfin je veux dire un bon paquet oui... en tout cas ca se prèsente plutot bien.
Google+    
Kris Membre non connecté

Villageois

Rang

Avatar

Inscrit le : 08/07/2013 à 23h09

Messages: 366

Le 22/07/2013 à 18h08
Bon courage avec cette chaleur; faut souder la nuit en ce moment :)


Kris - Old CPU addict
   
Jipe Membre non connecté

Maire-adjoint

Rang

Avatar

Association

Inscrit le : 02/10/2009 à 19h41

Messages: 9531

Le 22/07/2013 à 18h12
j'ai essayé mais on y voit rien et si on met le spot pour éclairer on arrive vite a une chaleur élevée :fou


:noel
Site web    
igal Membre non connecté

Conseiller Municipal

Rang

Avatar

Association Groupe : Shoutbox

Inscrit le : 29/07/2010 à 17h19

Messages: 5488

Le 22/07/2013 à 22h19
J'ai éteint le fer y a 30 minutes, Je m'en suis pas tellement rendu compte mais une fois qu'on sort la tête du schéma, de grosses bouffées de chaleur :sick

Quoi qu'il en soit, autant j'ai mis du temps à imaginer l'ajout de certaines options, autant cet après midi j'ai beaucoup avancé.

Tous les Signaux Puces <= à => Puces est terminé :top (Surlignés en marron).

La prochaine fois, il me restera à câbler les signaux natifs du BUS MSX ainsi que le câblage spécifique depuis les Jumpers => [SlotSlt], [BusDir] et [Int] sur les 6 connecteurs EDGE.
Pour rappel, seuls 4 au maximum (au choix) seront utilisables en tant que Slot étendus. Deux d'entre eux (au choix) seront IO seulement.

Voici en image:


Petite précision:
Afin d'éviter des problèmes, je souderai les signaux câblés sur les Pins Impaires en premier (rangée du dessus) puis Paires en second (rangée du dessous).
Cela évite de faire fondre le câble à proximité ;)

La suite dans la semaine... Edité par igal Le 22/07/2013 à 22h21


Tiens... voila du boudin, voila du boudin, voila du boudin... :siffle
Kris Membre non connecté

Villageois

Rang

Avatar

Inscrit le : 08/07/2013 à 23h09

Messages: 366

Le 23/07/2013 à 08h48
ça prends sérieusement forme !!


Kris - Old CPU addict
   
igal Membre non connecté

Conseiller Municipal

Rang

Avatar

Association Groupe : Shoutbox

Inscrit le : 29/07/2010 à 17h19

Messages: 5488

Le 23/07/2013 à 09h29
C'est super long à faire :oups

Vu le prix des expanders, ça vaudrait peut être le coup de fabriquer de faire fabriquer les PCB puis d'y ajouter nous même les composants.



Mon tel voit mieux le jour que la nuit :p




Tiens... voila du boudin, voila du boudin, voila du boudin... :siffle
igal Membre non connecté

Conseiller Municipal

Rang

Avatar

Association Groupe : Shoutbox

Inscrit le : 29/07/2010 à 17h19

Messages: 5488

Le 25/07/2013 à 14h16
Après 2 jours à débugger l'Expander de Galine, toujours pas moyen de démarrer le MSX normalement.

Tout d'abord, voici la particularité de l'Expander.

Tous les signaux sont récupérés depuis le BUS MSX et envoyés en parallèle sur tous les connecteurs sauf les signaux suivants:
Pin 4 [Slot select] / Pin 8 [Int] / Pin 10 [BusDir]
[slotSelect] et [BusDir] sont envoyés vers les LS respéctifs. [Int] est quant à lui prévu pour être relié X.0, X.1, X.2 et X.3. (Pas les connecteurs 5 et 6 qui sont I/O)
Nb: En attendant de solutionner mon problème, je n'ai même pas relié les sorties [Slot Sel] ni [BusDir] sur les connecteurs correspondant X.0, X.1 etc...

Voici la photo du montage:


En rouge => +5V
En noir => GND
En Bleu => Les signaux venant des Pins Paires du BUS MSX.
En jaune => Les signaux venant des Pins Impaires du BUS MSX.
En gris => Les signaux venant d'une Puce allant vers une autre Puce (Sauf SlotSel, Int et BusDir)

Tout en bas à gauche en gris => Colonne gauche [Slot Select], Colonne du centre [Int] et Colonne de Droite [BusDir].
Les signaux sont en réserve de bas en haut pour X.0, X.1, X.2 et X.3. (INT restant identique pour les 4)

Surlignés en Bleu, la bonne connexion du câblage vérifiés un à un coté soudure.
Les Points en orange, la bonne connexion du câblage vérifié depuis les Pattes des CI. (Au cas ou les Sockets auraient été deffectueux!).



Vue du dessus avec les connecteurs:

On peut voir que par manque de CI, j'ai remplacé
74LS08 par 74HC08
74LS00 par 74HC00
74ALS32 par 74HC32
74ALS540 par 74HC540
74ALS11 par 74LS11
74ALS133 par 74LS133
74ALS139 par 74LS139
74ALS352 par 74LS352
74ALS273 par 74LS273

Les symptômes:
1) J'allume le MSX => Ecran Noir. On voit le tramage sur le fond d'écran propre au VDP, mais l'écran reste figé noir.
2) Je change TOUS les CI (sauf 74LS193 j'en ai plus):
3) J'allume le MSX => OK.
3b) Je reboot => Ecran noir.
3c) j'éteint puis je rallume => Ecran Noir.
4) Si je retire TOUS les CI, le MSX redémarre.
4b) Si je retire seulement le CI 74HC08, le MSX redémarre.
5) Toutes les Pins sont vérifiées, (1 à 50, il n'y a aucun court circuit!)

Nb1: Avec ou sans Buffer Addon, les résultats sont les mêmes.
Nb2: L'autre Expander fonctionne normalement en ayant les CI suivants:
74LS08 par 74LS08
74LS00 par 74LS00
74ALS32 par 74LS32
74ALS540 par 74HC540
74ALS11 par 74LS11
74ALS133 par 74LS133
74ALS139 par 74LS139
74ALS352 par 74LS352
74ALS273 par 74LS273

J'espère ne pas avoir été trop confus.

En espérant vôtre aide :p Edité par igal Le 25/07/2013 à 14h22


Tiens... voila du boudin, voila du boudin, voila du boudin... :siffle
Jipe Membre non connecté

Maire-adjoint

Rang

Avatar

Association

Inscrit le : 02/10/2009 à 19h41

Messages: 9531

Le 25/07/2013 à 14h43
si tu retires le LS08 et que ça fonctionne c'est que le probléme est au niveau des /BUSDIR

essai une résistance de 4,7K entre chaque entrée /BUSDIR et le +5V


:noel
Site web    
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie