MSX Village forum

L'atelier Mapper 128Ko Gouget

Fabf Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 24/08/2010 à 20h55

Messages: 4833

Le 20/07/2012 à 18h42
J'ai tenté de réaliser un mapper 128ko en m'inspirant du mapper 512ko de Gouget
http://msx.gouget.com.br/?p=65

J'ai câblé une 681000 selon de schéma ci dessous


Donc forcément ça ne marche pas :gre

Quand je lance TESTRAM celui ci se fige

Si j'enlève CS2 TESTRAM se lance mais ne trouve pas mapper

J'ai bien revérifié mais je vais revoir ça

Si Jipe à une idée ;) Edité par Fabf Le 28/07/2012 à 10h49
Jipe Membre non connecté

Maire-adjoint

Rang

Avatar

Association

Inscrit le : 02/10/2009 à 19h41

Messages: 9531

Le 20/07/2012 à 19h40
met le CS2 au plus 5V pour qu'il soir actif

les signaux / eux sont actifs a l'état bas donc seront relié au 0v


:noel
Site web    
Fabf Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 24/08/2010 à 20h55

Messages: 4833

Le 20/07/2012 à 20h08
CS2 (CE2 sur le schéma) est déjà au +5V
Quels signaux je dois mettre au 0V ?
granced Membre non connecté

Maire-adjoint

Rang

Avatar

Association

Inscrit le : 09/10/2009 à 09h18

Messages: 1485

Le 20/07/2012 à 20h38
Sans déconner les mecs, la taille des photos quoi... :(


MSX un jour, MSX toujours ! :D
Site web    
Fabf Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 24/08/2010 à 20h55

Messages: 4833

Le 20/07/2012 à 22h27
Désolé, j'ai abusé :oups
Redimensionné à 352ko, en dessous on voit rien
Je précise que toutes mes photos sont sur mon FTP et donc n'occupent pas d'espace sur le site ;)
granced Membre non connecté

Maire-adjoint

Rang

Avatar

Association

Inscrit le : 09/10/2009 à 09h18

Messages: 1485

Le 21/07/2012 à 09h41
C'est pas tant la taille sur le site mais la visibilité qui me gêne :oups
Pas pratique de devoir utiliser les "ascenseurs" pour voir les différentes partie d'une image


MSX un jour, MSX toujours ! :D
Site web    
Jipe Membre non connecté

Maire-adjoint

Rang

Avatar

Association

Inscrit le : 02/10/2009 à 19h41

Messages: 9531

Le 21/07/2012 à 11h06
pour voir en entier il suffit de cliquer 2éme bouton , afficher l'image

il faut garder les schémas dans une taille lisible , ce n'est pas comme une photo la preuve moi je lis -5V sur le CE2

je les sauvegarde et les ouvre avec photophiltre pour travailler dessus et au besoin les imprime

sauvegardé en PNG le schéma du mapper d'igal ne fait que 28k

pour Fabf il faut respecter les vrais noms des signaux /WE /CE /OE CE2 au besoin regarder le data sheet du composant

ton mapper il est en interne ou en externe et dans quelle machine ?


:noel
Site web    
Fabf Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 24/08/2010 à 20h55

Messages: 4833

Le 21/07/2012 à 11h47
Je vais revoir le schéma en changeant le nom des signaux :oups

J'ai testé le mapper sur un V20 en slot 1 et 2 en désactivant le slot 3
Le MSX ne démarre pas

J'ai aussi testé sur d'autres MSX1 en externe
Le MSX démarre mais TESTRAM fige


Jipe Membre non connecté

Maire-adjoint

Rang

Avatar

Association

Inscrit le : 02/10/2009 à 19h41

Messages: 9531

Le 21/07/2012 à 12h04
ça ne suffit de désactiver le slot 3 pour désactiver la mémoire

as tu une machine ou tu pourrais dessouder les RAM et les LS157 ?

si TestRam marche c'est que le dos est chargé donc le MSX voit bien 64k

ce mapper simplifié ne permet pas la lecture des pages par IN A,(FFH) - IN A,(FEH) - IN A,(FDH) - IN A,(FCH)

seul l'écriture est possible par OUT (FFH),A - OUT (FEH),A - OUT (FDH),A - OUT (FCH),A

pour rappel les MSX1 n'initialisent pas le mapper au démarrage ( essai plutôt avec ta cartouche MSX2 dans un slot )

il faudrait une routine
AF XOR A
D3FF OUT(FFH),A
3C INC A
D3FE OUT(FEH),A
3C INC A
D3FD OUT(FDH),A
3C INC A
D3FC OUT(FCH),A
dans un coin libre de ta rom MSX1 et qui se lance a l'init


:noel
Site web    
Fabf Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 24/08/2010 à 20h55

Messages: 4833

Le 21/07/2012 à 12h25
En gros il faut faire plein de tests mais malheureusement ma carte MSX2 est out suite au grillage du VDP (enfin j'espère)

Je reprendrais les tests dès que j'en aurais reçu
Jipe Membre non connecté

Maire-adjoint

Rang

Avatar

Association

Inscrit le : 02/10/2009 à 19h41

Messages: 9531

Le 21/07/2012 à 13h21
comment as tu fait pour griller le VDP ?


:noel
Site web    
Fabf Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 24/08/2010 à 20h55

Messages: 4833

Le 21/07/2012 à 18h43
J'ai enlevé le /INT et depuis plus rien :oups
Jipe Membre non connecté

Maire-adjoint

Rang

Avatar

Association

Inscrit le : 02/10/2009 à 19h41

Messages: 9531

Le 21/07/2012 à 19h01
est ce que tu l'a retiré sous tension ?

ce signal d'interruption est un signal de sortie qui est envoyé sur l'entrée /INT du CPU

le MSX travaille en permanence avec ce signal d' interruptions provenant du VDP , il est indispensable


:noel
Site web    
Fabf Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 24/08/2010 à 20h55

Messages: 4833

Le 21/07/2012 à 19h04
Non je crois pas, on verra bien quand j'aurais reçu mes VDP

Pour la mapper Gouget, au début j'avais oublié d'alimenter le 74ls688
TESTRAM m'indiquait MAPPER 48KO et bien sur un message d'erreur lors du test

Je vais tester le mapper sur un MSX2 64ko
Jipe Membre non connecté

Maire-adjoint

Rang

Avatar

Association

Inscrit le : 02/10/2009 à 19h41

Messages: 9531

Le 21/07/2012 à 19h07
les alims des CI n'apparaissent jamais sur les schémas !!

faut juste y penser , moi je les cable en premier ;)


:noel
Site web    
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie