MSX Village forum

L'atelier connecter un clavier de philips nms 8250/80 a la place du clavier d'origine du canon v20?

galine Membre non connecté

Conseiller Municipal

Rang

Avatar

Inscrit le : 27/08/2010 à 02h22

Messages: 1363

Le 26/03/2013 à 03h41
Je me demandais si il etait possible en remplacant le PPI d'origine du V20 de connecter un clavier de philips nms8250/80?

Je sais cette question peut paraitre etrange mais c'est pour tenter de remplacer le clavier d'un V20 démolis par un clavier que j'ai sous le coude.

Apres réflection je penses que ma question est stupide au vue du tas de choses que controle le PPI le remplacer aproterait sont lot de problemes comme des soucis de gestion de ram ou de slot. Edité par galine Le 26/03/2013 à 03h52
Google+    
Jipe Membre non connecté

Maire-adjoint

Rang

Avatar

Association

Inscrit le : 02/10/2009 à 19h41

Messages: 9531

Le 26/03/2013 à 07h53
les claviers ne sont que des matrices de lignes X et Y qui se connectent au PPI

il faut juste respecter le modéle AZERTY et QWERTY et vérifier les matrices







:noel
Site web    
Jipe Membre non connecté

Maire-adjoint

Rang

Avatar

Association

Inscrit le : 02/10/2009 à 19h41

Messages: 9531

Le 26/03/2013 à 08h27




attention le modéle 00 est en QWERTY


:noel
Site web    
galine Membre non connecté

Conseiller Municipal

Rang

Avatar

Inscrit le : 27/08/2010 à 02h22

Messages: 1363

Le 26/03/2013 à 10h45
les deux claviers semblent tres tres proches cela voudrait dire que si je m'implante en lieux et place du clavier d'origine je devrais parvenir a utiliser de nouveau le basic ca pour une bonne nouvelle c'est une bonne nouvelle ^^.

Google+    
Jipe Membre non connecté

Maire-adjoint

Rang

Avatar

Association

Inscrit le : 02/10/2009 à 19h41

Messages: 9531

Le 26/03/2013 à 10h53
le MSX étant basé sur une norme il est normal d'avoir des claviers semblables

la grosse différence est au niveau des lignes du pavé numérique qui ne sont pas gérées sur le V20

sur celui du 8250 on voit X0 et X0' la seule différence étant la diode , on retrouve cette diode sur les touches CODE GRAPH SHIFT du V20

j'ai déja vu en hollande un clavier de 8250 monté sur une carte de Turbo-R , le tout dans un boitier de PC


:noel
Site web    
galine Membre non connecté

Conseiller Municipal

Rang

Avatar

Inscrit le : 27/08/2010 à 02h22

Messages: 1363

Le 26/03/2013 à 11h32
Merci Jipe pour ces eclaircisements toujours au top a ce que je vois.

je vais donc me metre a l'ouvrage dans la semaine histoire de voir ce que cela peut donner j'ai le connecteur adéquoit a porté de main.

Concernant la bidouille sur le turbo-r j'en avais entendu parler et vue quelques exemples sur le net effectivement.

Google+    
galine Membre non connecté

Conseiller Municipal

Rang

Avatar

Inscrit le : 27/08/2010 à 02h22

Messages: 1363

Le 27/03/2013 à 13h02
La manip semble fonctionner, j'ai par contre une ligne complete qui semble etre a l'ouest la X4 je m'explique

gauche pavet de direction = 1
stop = gauche pavet de direction
code ne semble pas fonctionner (pas de beep touche)
z => ê
o =>oz
g => go
= => =g
< => <=
' => <'

la ligne X2 semble avoir le meme type de soucis je n'arrives pas trop a comprendre c'est comme s'il y avait un faux contact sur le montage mais les mesures au multimetre n'ont rien donné.

je me demandais si ce bug ne pouvait pas venir du clavier que j'utilises le V20 est en azert alors que le clavier philips lui est en qwerty

ce qui m'etonnes le plus c'est que le reste est bon.

J'ai tenté l'inversion du X2 avec le X4 mais les choses sont pire encore vue que la la matrice se retrouve completement chamboulée.

j'ai egalement fais des essais en jeux et la le gauche du pavet directionel est fonctionel ce qui me fait pensser qu'il y a un melange quelque part.




Google+    
Jipe Membre non connecté

Maire-adjoint

Rang

Avatar

Association

Inscrit le : 02/10/2009 à 19h41

Messages: 9531

Le 27/03/2013 à 22h37
il y a une répétition dans la matrice Y0+Y1 , Y1+Y2 etc

le montage des diodes n'est pas identique sur les 2 machines

tu peux essayer de shunter D604 D605 D606

mais ça, peux être aussi du a la longueur des cables


:noel
Site web    
galine Membre non connecté

Conseiller Municipal

Rang

Avatar

Inscrit le : 27/08/2010 à 02h22

Messages: 1363

Le 28/03/2013 à 09h38
J'ai cherché un momment les dites diodes quand je me suis demandé si ces dernieres n'etaient pas tout bonement cachées dans le clavier lui meme ^^.

Bon je vais tester le shint car je viens de racourcir ma nappe de déport sans plus de résultat.

J'y penses je n'avais pas raccordé le +5v a la prise j'avais betement penssé que ce dernier ne servait qu'a la led mon soucis ne pourrait-il pas venir de la?



Google+    
Jipe Membre non connecté

Maire-adjoint

Rang

Avatar

Association

Inscrit le : 02/10/2009 à 19h41

Messages: 9531

Le 28/03/2013 à 11h33
le 5v ne sert qu'a la led

les diodes sont bien planquées dans le clavier


:noel
Site web    
galine Membre non connecté

Conseiller Municipal

Rang

Avatar

Inscrit le : 27/08/2010 à 02h22

Messages: 1363

Le 28/03/2013 à 15h46
Si les bien compris a l'origine les diodes servent a "démultiplexer le signial pour apporter les options spécifiques au clavier du nms 8050 genre clavier numerique.

Tu m'avais parlé de shunter les diodes D604 A D606 mais il n'y a pes eu l'effet escompté par contre je me demandais si il n'etais pas envisageable de suprimer les X et Y' qui finalement foute la zonne et par la meme occasion ejecter les diodes.

Car le reste du clavier fonctionne sans diodes et ca passe bien donc... Edité par galine Le 28/03/2013 à 19h31
Google+    
TurboSEB Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++ Groupe : Shoutbox

Inscrit le : 08/08/2010 à 20h57

Messages: 5494

Le 28/03/2013 à 18h33
Interessant ^^

Et ca serait pas un plus, si l'on pouvait adapter un clavier PC ou autres, beaucoup plus facile a trouver, enfin en principe^^ Edité par TurboSEB Le 28/03/2013 à 18h33



MSX 1&2 + Moniteurs+divers (environ 0.70Tonnes)
   
galine Membre non connecté

Conseiller Municipal

Rang

Avatar

Inscrit le : 27/08/2010 à 02h22

Messages: 1363

Le 28/03/2013 à 19h30
Les adaptateurs clavier pc => msx existent depuis longtemps regardes chez padial ^^.

Et si je n'arrives pas mieux a m'en sortir je crois que ca va se finir comme ca car la je ne comprends pas
-_-.
Google+    
Fabf Membre non connecté

Conseiller Municipal

Rang

Avatar

Groupe : compte ++

Inscrit le : 24/08/2010 à 20h55

Messages: 4833

Le 28/03/2013 à 20h00
C'est chiant, ça marche jamais du premier coup :(
galine Membre non connecté

Conseiller Municipal

Rang

Avatar

Inscrit le : 27/08/2010 à 02h22

Messages: 1363

Le 28/03/2013 à 20h16
C'est clair et la chose la plus etrange c'est que quand je fais les connections une a une sur le connecteur et que je verifie tout est OK la par exemple j'ai monté mon Y0 et tous mes X et au bout de quelque temps paf ca se met a délirer

Je penses que je vais ejecter le connecteur clavier d'origine c'est domage j'avais fais un zoli connecteur qui permetait le démontage en cas de besoin -_-.

Google+    
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie