MSX Village forum

L'atelier » Slot Expander

Conseiller Municipal

rank_5.png

Avatar

Association

Inscrit le: 29/07/2010

Messages: 4996

Le 29/04/2012 à 12h17
Reprise du message précédent

En réponse à Fabf:

La nappe utilisée fait 70Cm de longueur et il y a 3 connecteurs IDC50 sertis dessus.
Je ferai l'essai avec un nappe de 80Cm on verra si l'AddOn tient les signaux sur cette longueur ;)

Conseiller Municipal

rank_5.png

Avatar

Association

Inscrit le: 29/07/2010

Messages: 4996

Le 16/05/2012 à 14h57
J'ai fabriqué provisoirement un boîtier pour mon expander à partir d'un Boitier DVD SLIM.

Il a rien de transcendant, mais il ne demande que quelques minutes à mettre en oeuvre et protège parfaitement le circuit spaghetti flanqué sous la bakélite ;)

Vue des différents éléments:


La bakélite glissée dans les onglets de maintiens prévus pour un feuillet:


Le boîtier refermé:


De dessous: Il faut supprimer le moulage de l’emprunte DVD pour que la Bakélite soit bien à plat.


Voici le résulta:




Encore une fois, c'est du provisoire, mais rapide et pratique. :top

Maire-adjoint

rank_special.png

Avatar

Inscrit le: 06/10/2009

Messages: 606

Le 16/05/2012 à 15h18
Ca protège et c'est pas cher, j'aime bien des idées comme cela ! :top


MSX Turbo-R FS A1GT - 1 Mo de RAM - Disque dur SCSI Syquest cartouches de 270 Mo - Lecteur CD. Musique, musique, musique et encore musique !
   

Conseiller Municipal

rank_5.png

Avatar

Association

Inscrit le: 24/08/2010

Messages: 4799

Le 16/05/2012 à 15h34
Impécable :top

Maire-adjoint

rank_special.png

Avatar

Association

Inscrit le: 02/10/2009

Messages: 9080

Le 16/05/2012 à 15h39
en plus c'est le slot le plus plat que j'ai jamais vu ;)


:noel
Site web    

Maire-adjoint

rank_special.png

Avatar

Association

Inscrit le: 02/10/2009

Messages: 2396

Le 21/05/2012 à 21h58
Magnifique :top
En plus on a droit à la photo d'Igal lui-même dans le reflet :D
   

Conseiller Municipal

rank_5.png

Avatar

Association

Inscrit le: 29/07/2010

Messages: 4996

Le 21/05/2012 à 22h27
Merci Franck.

Le petit plus de cet Expander.

6 connecteurs Edge.
4 Slot [X,0] [X,1] [X,2] [X,3] + [3.1] + (en réflexion [I/O] ou [Slot 1 ou 2 déplacé] :moue )
Compatible tout MSX :top
Nb: L'intêret du Slot Déplacé étant de ne plus avoir à débrancher l'Expander pou connecter une Cartouche à sa source ;)
Exemple: L'Expander branché sur le Slot 2, le slot déplacé devient un [Slot Déplacé 2] et utilisable comme un Slot 2 "normal". Ca évite de débrancher l'Expander en cas de nécessité absolu du PORT source :top :top :top




Conseiller Municipal

rank_5.png

Avatar

Association

Inscrit le: 29/07/2010

Messages: 4996

Le 04/10/2012 à 22h14
Après quelques mois de veille, le dernière ligne droite pour finir l'expander à la sauce Jipe :p


Chaque Slot étendu a deux Jumpers cote à cote.
En Jaune, le Jumper [Slot Select] et en Bleu, le Humper [Busdir].
L'idée étant d'avoir la liberté de Jumper indépendamment l'un ou l'autre des signaux si l'on veut.


Fléchées en Orange, les dérivations des Signaux [SlotSelect] et [BusDir] générés dans le MSX (Merci Jipe) et dérivés sur les Pin 5 et 16 du Slot MSX.
Nb: Astuce rapporté par Jipe, et utilisée sur le Turbo-R :top


Vue générale de dessous.

Demain:
je ferai la dérivation des signaux [BusDir] et [SlotSelect] sur la Carte Mère.
Je câblerai les Jumpers [X.1, X.2, X.3, X.4]

Edit: Les Pins 5 et 16 sont inutilisées sur le Standard ;)



Edité par igal Le 04/10/2012 à 22h20

Conseiller Municipal

rank_5.png

Avatar

Association

Inscrit le: 29/07/2010

Messages: 4996

Le 12/10/2012 à 23h55
Encore un peu d"aide :p

A la suite de la réparation des Slots 1 et 2, j'ai testé le bon fonctionnement de l'expander.

Tout fonctionne sur tous les SLOTS étendus sauf la CF de Sunrise qui ne fonctionne que sur les SLOTS X.0

En d'autres mots, sur le Port Edge 0 de l'expander relié au slot 1 ou 2 du MSX.

J'ai beau chercher, mais je me rend compte n'avoir jamais essayé de brancher la CF sur les SLOT X.1; X.2 ou X.3, donc je n'ai pas de point de comparaison :moue

Toutefois, les MoonSound, Music Modules, SCC et Double mégaroms fonctionnent très bien sur les SLOT X.1; X.2 et X.3

Le seul SLOT étendu sur lequel j'avais testé la CF Sunrise est le 3.1 qui fonctionne très bien comme on peut le voir sur cette photo:


@Fabf: Peux tu me dire si ta CF fonctionne sur tes SLOTS étendus X.1, X.2 ou encore X.3?

@Jipe; Tu as une idée de teste/Checkup à faire avec ma shtite Diode?

:tchin :tchin :tchin
GDX

Conseiller Municipal

rank_5.png

Avatar

Inscrit le: 17/01/2011

Messages: 3064

Le 13/10/2012 à 03h08
igal :


Tout fonctionne sur tous les SLOTS étendus sauf la CF de Sunrise qui ne fonctionne que sur les SLOTS X.0


C'est possible que la CF de Sunrise entend le SLOT pour mettre son BIOS et le MSX-DOS2 en même temps. Si c'est le cas, c'est normal.
   

Conseiller Municipal

rank_5.png

Avatar

Association

Inscrit le: 29/07/2010

Messages: 4996

Le 13/10/2012 à 10h16
Salut GDX.

Si tel était le cas, les Ports X.1, X.2 et X.3 ne seraient pas fonctionnels lorsque la CF serait insérée sur X.0 non?

D'autre part, on voit sur la photo au dessus, que la CF fonctionne sur le Slot 3.1 qui est en l'équivalent d'un X.1 non?

En fait, je me demande si en ayant fait la dérivation des Pin 5 et 13 sur l'Expander, peut être qu'une porte logique à ramassée :oups

Edit:
Pourtant, J'utilise la CF en X.0, Le Music Module en X.1, la MoonSound en X.2 et le Midi Pac en X.3. Ainsi, tout fonctionne.

Un point étrange, il est vrai qu'en mettant la CF sur X.0, je peux pas mettre de Music Module sur le SLOT 2 ou 1 :heink
Par contre, Si je met un Music Module sans la ROM sur le SLOT 1 ou 2, la CF fonctionnera sur X.0 :moue


Je pense vraiment qu'il est nécessaire de vérifier les circuits et voir ce qui va et ce qui va pas.



Edité par igal Le 13/10/2012 à 11h19

Conseiller Municipal

rank_5.png

Avatar

Association

Inscrit le: 24/08/2010

Messages: 4799

Le 13/10/2012 à 11h51
Je n'ai pas de CF mais une IDE
Elle fonctionne avec l'expandeur

Conseiller Municipal

rank_5.png

Avatar

Association

Inscrit le: 29/07/2010

Messages: 4996

Le 13/10/2012 à 14h04
Merci FabF.

Tu veux dire qu'elle fonctionne sur tous les SLOTS étendus ou alors juste sur X.0?

Chez moi, sur X.1, X.2 et X.3 j'obtiens ce message lors du BOOT:

1) Détection du premier CF

2) Affiche ce message à la place du second CF => WARNING DATA CORRUPTED DETECTED.



Maire-adjoint

rank_special.png

Avatar

Association

Inscrit le: 02/10/2009

Messages: 9080

Le 13/10/2012 à 14h50
j'ai testé pour vous la Sunrise CF ATA-IDE dans un slot expander sur un 8280 a 4Mo -> ça fonctionne trés bien dans les 4 slots étendus sur slot 1 et 2

j'ai poussé le vice a insérer une Sunrise ATA-IDE munie d'un adaptateur double Compact Flash

les 2 cartouches cohabitent trés bien et ce dans n'importe quel ordre avec boot fat 12 ou boot fat16

d'aprés ce que je comprends :

avec ta CF tu n'as pas de soucis dans un slot normal

avec ton slot expander la 1ére CF maitre est détectée et la seconde slave te donne un message DATA CORRUPTED

tu perd peut être trop de tension pour alimenter la seconde CF correctement

as tu essayé de mettre une autre CF pour voir ?


:noel
Site web    

Conseiller Municipal

rank_5.png

Avatar

Association

Inscrit le: 29/07/2010

Messages: 4996

Le 13/10/2012 à 16h28
Salut Jipe:

En fait j'expliquait que le

CF ATA-IDE de Sunrise avec 2 CF insérées me donne le résulta suivant:

1) Slot 1.0 => OK.
2) Slot 1.1 => WARNING DATA CORRUPTED DETECTED.
3) Slot 1.2 => WARNING DATA CORRUPTED DETECTED.
4) Slot 1.3 => WARNING DATA CORRUPTED DETECTED.

5) Slot 2.0 => OK.
6) Slot 2.1 => WARNING DATA CORRUPTED DETECTED.
7) Slot 2.2 => WARNING DATA CORRUPTED DETECTED.
8) Slot 2.3 => WARNING DATA CORRUPTED DETECTED.


Effectivement, le comportement avec une ou deux CF n'est pas le même :moue

CF ATA-IDE de Sunrise avec 1 CF insérées me donne le résulta suivant:

1) Slot 1.0 => OK.
2) Slot 1.1 => Logo MSX puis ecran bleu, un fraction de seconde écran noir puis écran bleu (en boucle)
3) Slot 1.2 => Logo MSX puis ecran bleu, un fraction de seconde écran noir puis écran bleu (en boucle)
4) Slot 1.3 => Logo MSX puis ecran bleu, un fraction de seconde écran noir puis écran bleu (en boucle)

5) Slot 2.0 => OK.
6) Slot 2.1 => Logo MSX puis ecran bleu, un fraction de seconde écran noir puis écran bleu (en boucle)
7) Slot 2.2 => Logo MSX puis ecran bleu, un fraction de seconde écran noir puis écran bleu (en boucle)
8) Slot 2.3 => Logo MSX puis ecran bleu, un fraction de seconde écran noir puis écran bleu (en boucle)

@Jipe: t'aurais pas un teste à me suggérer avec une diode et voir si un CI est défaillant!


Maire-adjoint

rank_special.png

Avatar

Association

Inscrit le: 02/10/2009

Messages: 9080

Le 13/10/2012 à 16h39
soit un signal qui sert aux CF et pas au jeux est défaillant

soit le 5V est écroulé en bout de ta limande essai de mettre un condensateur 470µF 16V en bout de ton expander entre pin 45 et 43
!! attention aux polarités


:noel
Site web    
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie
4 Utilisateurs en ligne : 0 Administrateur, 0 Modérateur, 0 Membre et 4 Visiteurs
Utilisateurs en ligne : Aucun membre connecté