MSX Village forum

L'atelier » Slot Expander

Maire-adjoint

rank_special.png

Avatar

Association

Inscrit le: 02/10/2009

Messages: 9124

Le 28/04/2012 à 12h56
Reprise du message précédent

pour la FMPAK le signal /BUSDIR n'est pas utilisé et comme le /SLTSL n'est pas cablé ça fait un signal/OE de la rom a 0 en permanence donc tout ce qu'il faut pour démarrer :gne


:noel
Site web    

Conseiller Municipal

rank_5.png

Avatar

Association

Inscrit le: 29/07/2010

Messages: 5014

Le 28/04/2012 à 16h03
J'ai réparé mon inversion et j'ai fais les testes suivants:

Avec la Fm Stéréo PAK => CALL FMPAK, les symptômes sont les suivants:
SLOT PAR => OK
SLOT OE=> OK
SLOT X.3 => SYNTAX ERROR ( avec l'inversion, j'avais => FREEZE dès CALL FMPAK)
SLOT X.2 => SYNTAX ERROR
SLOT X.1 => SYNTAX ERROR
SLOT X.0 => OK => RESET

Avec la Fm Stéréo PAK =>FEEDBACK, les symptômes sont les suivants:
SLOT PAR => OK
SLOT OE => OK
SLOT X.3 => PSG ( avec l'inversion, j'avais => OK)
SLOT X.2 => PSG
SLOT X.1 => PSG
SLOT X.0 => OK (( avec l'inversion, j'avais => KO)

Avec un MégaFlashRom SCC => SpaceManbow, les symptômes sont les suivants:
SLOT PAR => OK
SLOT ORP=> BASIC
SLOT X.3 => BASIC => ( avec l'inversion, j'avais => ECRAN BLANC => KONAMI => ECRAN BLANC => KONAMI etc..)
SLOT X.2 => BASIC
SLOT X.1 => BASIC
SLOT X.0 => KONAMI => ECRAN BLANC => KONAMI => ECRAN BLANC => Etc... ( avec l'inversion, j'avais => KO)

En conclusion:
Le problème sur X.3 s'est déplacé sur X.0 et le problème qui était sur X.0 s'est déplacé sur X.3
J'ai réparé l'inversion causée par mon dessin. Il me reste à vérifier/corriger les reste des câbles soudés!
Je pense particulièrement à la série [U1, U2 et U3]

T'as un test à me suggérer Jipe?

Maire-adjoint

rank_special.png

Avatar

Association

Inscrit le: 02/10/2009

Messages: 9124

Le 28/04/2012 à 16h09
la FMPAk est un mauvais exemple car la commande call fmpak ne marche pas dans un slot étendu 1 2 ou 3

commence par essayer des cartouches originales 32k puis une mégarom originale pour voir les comportements


:noel
Site web    

Conseiller Municipal

rank_5.png

Avatar

Association

Inscrit le: 29/07/2010

Messages: 5014

Maire-adjoint

rank_special.png

Avatar

Association

Inscrit le: 02/10/2009

Messages: 9124

Le 28/04/2012 à 16h33
il va absolument que je trouve un truc pour faire paraitre les alims des CI sur mes prochains shémas :'(

moi je cable le +5V et le GND en premier comme cela je n'en oublie pas ;)


:noel
Site web    

Maire-adjoint

rank_special.png

Avatar

Association

Inscrit le: 02/10/2009

Messages: 9124

Le 28/04/2012 à 16h42
aprés toutes ces tortures sur les CI ce sera un miracle si ça démarre du premier coup :)

le test ultime c'est 2 roms konami qui se combinent ex : nemesis 2 et penguin adv


:noel
Site web    

Conseiller Municipal

rank_5.png

Avatar

Association

Inscrit le: 29/07/2010

Messages: 5014

Le 28/04/2012 à 16h50
Merci beaucoup Jipe:

Mission Completed ;)

J'ai simplement branché +5V et GND puis j'ai testé directement la [MégaflasRom SCC 512] avec chargé dedans, [SpaceManbow 256Ko].

Slot X.0 => OK
Slot X.1 => OK
Slot X.2 => OK
Slot X.3 => OK
Slot Sans SLTSL ni BUSDIR => KO (ce qui est normal je crois)
Slot I/O => OK (slot strictement parallèle)

Prochaine étape:
1) implanter le Slot 3.1 sur l'expander
2) ajout des interrupteurs et les LED d'activité
3) Fabrication d'un boitier (peut être en Plexiglas ^^ )

En tout cas, merci de ton aide :top

Edit: Le Buffer Add'On fait des merveilles.
J'ai plus de 80 CM de nappe je crois et ça fonctionne parfaitement :kiss



Edité par igal Le 28/04/2012 à 16h52

Maire-adjoint

rank_special.png

Avatar

Association

Inscrit le: 02/10/2009

Messages: 9124

Le 28/04/2012 à 16h55
c'est quoi ton slot i/o ? il est en parallele sur lequel ? un i/o n'a pas de /sltsl


:noel
Site web    

Conseiller Municipal

rank_5.png

Avatar

Association

Inscrit le: 29/07/2010

Messages: 5014

Le 28/04/2012 à 16h59
Non je me suis très mal exprimé..
Autant pour moi. C'est du Strictement parallèle, et non pas I/O.

Le fait qu'il soit strictement Parallèle et branché sur le SLOT 1, cela transforme Le Connecteur en SLOT1 NON?
Si on le met sur Slot 2, cela devient un Slot 2 non?

Maire-adjoint

rank_special.png

Avatar

Association

Inscrit le: 02/10/2009

Messages: 9124

Le 28/04/2012 à 17h09
on ne peut pas mettre 2 cartouches dans un tel systéme

le slot 1 quand il est étendu se divise en 4 sous slot 1.0 , 1.1 , 1.2 , 1.3 mais perd sa fonction de slot 1

donc avec ton systéme tu peux avoir en plus le slot 3.1 et un slot I/O ( sans slot select )


:noel
Site web    

Conseiller Municipal

rank_5.png

Avatar

Association

Inscrit le: 29/07/2010

Messages: 5014

Le 28/04/2012 à 17h10
J'ai retrouvé tes mots Jipe ;)



Jipe :
normalement ça devrait marcher vu que les autres fils de la limande non utilisés arrivent sur des broches N.C.

au vu du schéma ce sera le slot 2 qui sera étendu

broche 4 /SLTSL2

broche 5 /SLTSL1 NC

broche 10 /BUSDIR2

broche 46 /BUSDIR1 NC

broche 8 /EXINT2

broche 16 /EXINT1 NC

tous les autres signaux sont en paralléle




Donc à Priori, le SLOT strictement parallèle devrait être un SLOT 2.

Je ferai un essais avec OPF pour voir si il trouve la MégaFlasrom SCC sur le Slot 2 et on aura le Coeur Net :top

Maire-adjoint

rank_special.png

Avatar

Association

Inscrit le: 02/10/2009

Messages: 9124

Le 28/04/2012 à 17h17
individuellement ça va marcher mais tu risques d'avoir un probléme quand il y aura les 2 cartouches en paralléle sur le même slot

une cartouche normale et une cartouche étendue , le msx ne pourra pas gérer la cartouche du slot 2 et celle d'un slot étendu du fait que le slot select qui sert au slot normal est divisé en 4 sous slot et c'est le mêm signal qui devrait aiguiller les 2


:noel
Site web    

Conseiller Municipal

rank_5.png

Avatar

Association

Inscrit le: 29/07/2010

Messages: 5014

Le 28/04/2012 à 17h37
Tu veux dire que Une cartouche insérée sur le SLOT Parallèle risque d'interférer avec une cartouche insérée dans un des SLOTS étendus malgré les interrupteurs sur chaque SLOT étendu et un interrupteur sur le SLOT parallèle?

Je ferai des essais et voir si il peut y avoir un intérêt quelconque à ce montage.
Je pense déjà à certains jeux qui nécessitent un SCC sur le SLOT 2.
Il suffirait de plugger la cartouche sur le SLOT PARALLELE et désactiver les interrupteurs des autres slots étendus non?

Maire-adjoint

rank_special.png

Avatar

Association

Inscrit le: 02/10/2009

Messages: 9124

Le 28/04/2012 à 18h09
si tu désactive les autres cartouches ça devrait fonctionner mais alors ce n'était pas la peine de faire un slot expander
un simple slot selecteur aurait fait l'affaire

le but d'un slot expander c'est d'avoir plusieurs cartouches fonctionnant en même temps sans avoir a switcher manuellement de l'une a l'autre en permanence

ex : mega scsi , moonsound , graph9000


:noel
Site web    

Conseiller Municipal

rank_5.png

Avatar

Association

Inscrit le: 29/07/2010

Messages: 5014

Le 29/04/2012 à 12h17
En réponse à Fabf:

La nappe utilisée fait 70Cm de longueur et il y a 3 connecteurs IDC50 sertis dessus.
Je ferai l'essai avec un nappe de 80Cm on verra si l'AddOn tient les signaux sur cette longueur ;)
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie
2 Utilisateurs en ligne : 0 Administrateur, 0 Modérateur, 0 Membre et 2 Visiteurs
Utilisateurs en ligne : Aucun membre connecté